Qgis officiellement dans Debian Squeeze

Après plus de deux ans d'absence, QGis revient officiellement dans Debian ! Il est même arrivé dans Squeeze (c'est comme ça que je m'en suis aperçu ce matin en faisant un petit aptitude update && aptitude safe-upgrade).

Il s'agit de la version 1.4.0, qui est la dernière version officielle qui plus est ! Donc, plus besoin de se prendre la tête à compiler à la main comme je l'avais indiqué dans cet article. J'espère que ce logiciel qui est une référence en terme de SIG bureautique libre ne quittera pas de sitôt le projet Debian. Merci à l'équipe DebianGis et au mainteneur (Francesco Paolo Lovergine).

Attention toutefois, petit bémol: le paquet python-qgis utilise libsip4 pour faire fonctionner les modules python de QGis ! Malheureusement, la version dans Squeeze n'est pas la bonne (4.9 au lieu de 4.10), du coup, on se choppe un bug #568241 qui se traduit par l'affichage de RuntimeError: the sip module implements API v6.0 but the qgis.core module requires API v7.0. Rien de grave, le bug en question a été détecté sous sid et il faut juste attendre que la bonne version de la libsip4 arrive dans Squeeze, ce qui ne devrait plus trop tarder maintenant !

Bon, en dehors de ça, j'ai rédigé une procédure de migration de postGIS 1.3 vers postGIS 1.4 dans le wiki Debian (parce que normalement, toute recherche d'information sur Debian devrait commencer sur le wiki... je me trompe ?).

Cette procédure est générique et peut également vous intéresser si vous souhaitez migrer en même temps de postgreSQL 8.3 vers postgreSQL 8.4. Si vous êtes sous Debian Squeeze et que vous désirez utiliser PostGIS 1.4, vous y êtes d'ailleurs contraint !