Carte Belkin F5D7000 sous Ubuntu:

Introduction:

J’avais acheté une petite carte wifi pas chère (environ 35€) à la va vite avant noël histoire d’étendre un peu mon réseau local. A l’époque, j’avais regardé si cette carte fonctionnait sous Linux. J’avais eu des échos sur le site de ndiswrapper sur le fait que la carte Belkin F5D7000 sous plusieurs révisions était supportée. Mais, mon but premier était que ça fonctionne sous Ms Windows 98 pour un vieux PC (Celeron 500 avec 128 Mo de RAM seulement) à remettre en fonctionnement.

Première suprise:

La révision de cette carte Wifi est la V3000fr. Sous MS Windows 98, j’ai réussi à la faire fonctionner de manière pas trop stable: en gros, une fois sur deux, le DHCP ne fonctionnait pas et aucune connexion n’était disponible malgrès une configuration correcte du pilote. Certes mon réseau est en WPA (histoire d’être un peu secure !) et je présume que cette configuration vient un peu compliquer les choses. Toutefois, j’ai a peu près réglé le problème en mettant une adresse IP fixe sur l’appareil.

J’ai récupéré un disque dur un peu plus récent (et surtout plus rapide) pour le PC. Aussitôt, j’en ai profité pour tenter une installation de xubuntu (breezy) dessus. Le processus d’installation se déroule correctement et pendant que ça s’installe, je potasse quelques docs en ligne pour configurer la carte wifi. Dans ma tête ,ndiswrapper était censé fonctionner. Donc, ni une ni deux, je me lance à l’assaut de cette configuration dès la fin de l’installation de xubuntu (en fait , dès la fin de l’installation serveur de Ubuntu). Je récupère les pilotes MS Windows, les installe et apparamment, ndiswrapper reconnait mon matériel. Cependant, impossible d’obtenir la moindre configuration ni même un scan du réseau.

Je retourne sous Windows télécharger les derniers pilotes pour les différentes révisions de cette carte (V1 V2 V3 V4 V5 mais pas de v3000fr sur le site de belkin). Encore une fois, ndiswrapper est content mais pas de connexion, même en repassant sur un mode totalement non protégé de mon routeur wifi. De retour (encore) sous Windows, je regarde les infos du pilote et me rend compte que le chipset n’est pas un Connexant mais un Ralink. Google est mon ami et je tombe sur une bonne surprise: Ralink fait des pilotes OpenSource pour ses chipsets !!! Voilà qui a le mérite d’être clair.

En piste avec le bon pilote:

Muni de la doc qui va bien , je reviens sous Ubuntu et observe que dès le démarrage, un pilote rt2500 est bien lancé ! C’est celui-ci qui fonctionne et je pense qu’il prend le pas sur ndiswrapper. En conséquence, on jette ndiswrapper à la poubelle et on se focalise sur le pilote rt2500. Ce dernier est GPL et, encore plus facile, est intégré dans Ubuntu sous le paquet rt2500 ! Il ne nous reste qu’à le configurer correctement.

Un truc à savoir c’est que le périphérique ne se nomme pas wlan0 ou eth0 par défaut mais ra0. Néanmoins, j’ai rapidement déchanté: malgré le potassage de moult docs sur le net, pas moyen de faire fonctionner la carte ! Malgré le chargement avéré du pilote, pas de leds allumées ni de connexion. Je suis revenu en AP ouvert (sans protection) pour faire les diagnostics et j’ai réussi à ouvrir une connexion manuellement.

Ensuite, c’est le lancement de la connexion au démarrage (lancement de /etc/init.d/networking) qui s’est mise à planter: la connexion ne venait jamais, il fallait que je la lance à la main. Comme la personne qui utilise le PC en question n’a pas forcément envie de taper des commandes dans un shell, je me suis mis en tête de débugger le système. A force de diagnostics, je me suis rendu compte qu’il fallait, dans le processus de lancement, activer d’abord la carte avec ifconfig ra0 up avant toute autre chose. La configuration qui va bien:

Voici ma configuration actuelle et qui donne toute satisfaction: elle permet de relier le PC sous xubuntu à mon AP (Access-Point) en WPA PreSharedKey cryptée en AES.

fichier /etc/network/interfaces:

iface ra0 inet dhcp
pre-up ifconfig ra0 up
pre-up iwconfig ra0 mode Managed
pre-up iwpriv ra0 set AuthMode=WPAPSK
pre-up iwpriv ra0 set EncrypType=AES
pre-up iwconfig ra0 essid le_nom_de_votre_wlan
pre-up iwpriv ra0 set WPAPSK=LACLEFWPAQUIVABIEN 

25 Février 2006 at 13:06

Posted sam. 25 févr. 2006 12:06:00 Tags: